Jelenlegi hely

programozás

C++ ABI változás

A GCC 5.x verziótól a libstdc++ könyvtár új ABI-val (application binary interface-szel) érkezik, hogy megfeleljen a 2011-es C++ szabványnak.

Noha kompatibilitási okokból a régi C++ ABI is elérhető (a részleteket lásd itt), azt javasoljuk, hogy a repón kívüli, saját csomagokat fordítsátok újra az új ABI-hoz. Ez különösen akkor fontos, ha a csomag új ABI-val készült könyvtárhoz van linkelve. A következő shell-script kilistázza az újrafordítandó csomagokat:

hírek címkéi: 
Feliratkozás RSS - programozás csatornájára