Jelenlegi hely

frissítés

Linux 3.13 FIGYELMEZTETÉS: A PS/2 billentyűzet támogatás modulba került

Olyan kérés érkezett hozzánk, hogy az i8042 billentyűzet és egér vezérlő driver kerüljön át modulba. Néhány ilyen hardverrel nem rendelkező felhasználó ugyanis furcsa hibaüzeneteket kapott, és lelassult a boot folyamatuk. Tom megoldotta a problémát kerneloldalon (köszönjük), munkájának eredménye bekerült a 3.13-as kernelbe.

hírek címkéi: 

Az /etc/sysctl.conf megszűnik

A 207-es verziótól kezdve a systemd többé nem olvas beállításokat az /etc/sysctl.conf fájlból, csak az /etc/sysctl.d/*-ból. Mivel időközben a procps-ng csomagunk által szállított /etc/sysctl.conf fájl beállításai alapértelmezetté váltak a kernelben, úgy döntöttünk, hogy elavultnak minősítjük ezt a fájlt.

Amikor procps-ng-3.3.8-3-ra frissítesz, kapsz egy pacman-üzenetet a teendőkről, vagyis az egyéni /etc/sysctl.conf-beállítások /etc/sysctl.d-be helyezéséről. Ennek legegyszerűbb módja a következő:

hírek címkéi: 

A PHP 5.5 elérhető az [extra] repóban

A PHP 5.5 elérhető az [extra] repóban. A migrációs oldalon megtalálod a fontosabb változásokat az 5.4 verzióhoz képest, a részletes lista pedig a PHP Changelogban olvasható.

hírek címkéi: 

A TeXLive 2013 frissítés felhasználói közreműködést igényelhet

A TeXLive 2013 csomagok hamarosan elérhetőek lesznek az [extra] repóban: A TeXLive 2012-ről frissítő felhasználók a következő hibaüzenetbe futhatnak a TeX engine (pl. latex, xelatex, luatex) használatakor:
(Fatal format file error; I'm stymied)
Ez a probléma telepítéskor is észlelhető a pacman kimenetéből:
>>> texlive: recreating all formats...
/usr/bin/fmtutil: line 395: /usr/share/texmf/texconfig/tcfmgr: No such file or directory
fmtutil: config file `fmtutil.cnf' not found.
done.

hírek címkéi: 

A bináris fájlok /usr/bin-be mozgatásához felhasználói közreműködés szükséges

A következő frissítés alkalmával az alábbi hibaüzenetet fogod kapni:
error: failed to commit transaction (conflicting files)
filesystem: /bin exists in filesystem

Ugyanis mostantól a bináris fájlok helye egységesen a /usr/bin könyvtár. Ezzel a binárisok felesleges megkülönböztetését megszüntetjük, ezáltal egyszerűbbé válik a csomagok karbantartása. A változtatás hátteréről további információkat találsz a levelezőlistánkon.

hírek címkéi: 

A qt4 felváltja a qt-t

Az új qt4 csomag bekerült az [extra] repóba. Ezzel lecseréljük a jelenlegi qt csomagot.

Minden qt függőséggel rendelkező csomagot újra kell fordítani qt4 függőséggel. Mi ezt megtettük a hivatalos csomagokkal, azonban az AUR-os csomagoknál ez a felhasználó feladata.

hírek címkéi: 

Utolsó sysvinit figyelmeztetés

Ahogy korábban jeleztük, az initscripts-et nem teszteljük a továbbiakban, és a támogatása több csomagból is kikerült. Minden megmaradt felhasználójának a systemd-re kellene váltania.

Az initscripts-et, sysvinit-et és a különböző rc szkripteket eltávolítjuk a repókból, hogy egyértelmű legyen a fejlesztői csapat álláspontja.

Tom Gundersen, 2013-02-04

hírek címkéi: 

A filesystem-2013.01-1 és glibc-2.17-2 csomagokat egyszerre frissítsd!

Mivel a /lib szimlink átkerül a glibc csomagból a jóval megfelelőbb filesystem csomagba, a glibc-2.12-2 és filesystem-2013.01-1 csomagokat egyszerre kell frissíteni. Ez automatikusan megtörténik, amikor a "pacman -Syu" parancsot használod. Ne felejtsd el, hogy a részleges frissítések nem támogatottak, és soha ne használd a --force kapcsolót...

hírek címkéi: 

Vége az initscripts támogatásnak

Mivel már a systemd az alapértelmezett init rendszer, az initscripts csak minimális tesztelésben részesül. Erőforrások és érdeklődés hiányában az initscripts-specifikus hibákon nem sokat tudunk dolgozni, és esetleg zárni is fogjuk őket WONTFIX-szel.

Ezért felhasználóinknak azt tanácsoljuk, hogy mielőbb migráljanak systemd-re. Ehhez segítséget ad a wiki oldalunk.

hírek címkéi: 

A ConsoleKit-et felváltja a logind

A GNOME 3.6-tal a polkit és a networkmanager az [extra]-ba kerül, és ConsoleKit-et pedig eltávolítjuk a repókból. Azok a csomagok, melyek korábban igényelték a ConsoleKit-et, mostantól a systemd-logind-t használják. Ez azt jelenti, hogy a teljes értékű működés érdekében a rendszert systemd-vel kell indítani.

A GNOME mellett a KDE és az XFCE is érintett ebben a változásban.

Allan McRae, 2012-10-30

hírek címkéi: 

Oldalak

Feliratkozás RSS - frissítés csatornájára